Yolo controlled gen using too much power with enhancer

Vorg

Well-known endo
Joined
Jul 4, 2021
Messages
55
#1
I have a starter ship with 1 enhancer mod on the fuel chamber and using this code:

:FuelChamberUnitRateLimit=(100-:)StoredBatteryPower/100)) goto1

The problem is, when under load moving, both fuel usage and gen are at the same amount 40, 60 what ever. but when I cut engines, then the gen out jumps way up while the fuel stays the same. It acts as if the mod only works when the the engines are off even if it's still charging batteries.
 
Last edited:

Vorg

Well-known endo
Joined
Jul 4, 2021
Messages
55
#3
I was told in discord that the mods are broken atm and don't work correctly on moving ships.
 

shado20

Well-known endo
Joined
May 16, 2020
Messages
74
#4
well your above code has a typo in it
the one I posted will work, but I don't charge battery's to 100% (9,900 instead of 10,000)
 

Vorg

Well-known endo
Joined
Jul 4, 2021
Messages
55
#5
I did cut and paste your code. Saw the same thing. When you have the thrusters on, the mod stops working and both fuel usange and gen rate go to the same numbers.

Looking t the code I had posted, I don't see the typo you mention other then the forum turning part into a smiley face.
 
Last edited:

Throdnk

Active endo
Joined
Sep 5, 2021
Messages
41
#6
There are many reports that enhancers are not working correctly when the ship is moving. This seems to match your observation. So this wouldn't be fixable by an updated YOLOL script, we would need the devs to fix it. And as with many other things, there is stuff of higher priority.
 

shado20

Well-known endo
Joined
May 16, 2020
Messages
74
#7
o yes i missed that, the enhancers are the problem, not the code. this has been a problem yea back in alpha and has not been fixed yet.
 

Womble

Veteran endo
Joined
Jun 11, 2021
Messages
177
#8
It looks, from discussions elsewhere that they're not joking when they say an enhancer projects a beam into the reactor setup. And that the calculations for that beam lag behind the moving reactor, once you get under way.

Which is stupid. Why base it on a thing that has to be recalculated continuously as position changes? That's just shit program design. Calculate what's effected when the ship's structural status changes and vary that based on variable changes.
 

Vorg

Well-known endo
Joined
Jul 4, 2021
Messages
55
#11
It is needless overhead. Only time you need to recalc function of something is when it's design is changed. Then just back it in because the only reason it would change is if parts were added/removed.
 

shado20

Well-known endo
Joined
May 16, 2020
Messages
74
#12
the laser thing is for the T2 and T3, the T1 is on the device, but the T2,T3 enhance 2 and 3 blocks away
 

Womble

Veteran endo
Joined
Jun 11, 2021
Messages
177
#13
the laser thing is for the T2 and T3, the T1 is on the device, but the T2,T3 enhance 2 and 3 blocks away
Makes no difference to how wonky it is to code it as a real-time effect rather than calculating it when the ship's composition changes.
 
Top